Search Console

Googlebot nie może uzyskać dostępu do plików CSS i JS w witrynie – nowy komunikat Google

powiadomieniePo kilku dniach od wprowadzenia komunikatu o poprawie na stronie kwestii związanych z ruchem mobilnym Google serwuje nam nowy rodzaj powiadomienia – tym razem zwracający uwagę webmastera na zablokowane zasoby w CSS i/lub JS.

Temat blokady tych zasobów ostatnio jest poruszany np. na hangoutach z Johnem, na których wskazuje się niebezpieczeństwo dla witryny związane z blokadą tych zasobów przed Googlebotem

W celu zapewnienia optymalnego renderowania i indeksowania stron zawsze umożliwiaj Googlebotowi dostęp do plików JavaScript, CSS oraz obrazów, których używa Twoja witryna, by mógł widzieć ją tak, jak widzi ją użytkownik. Jeśli plik robots.txt Twojej witryny blokuje indeksowanie tych zasobów (…) może to doprowadzić do uzyskania przez witrynę gorszej pozycji w rankingu.

Więcej informacji na ten temat znajdziecie w materiałach Pomocy Google.

W nowym powiadomieniu – tym razem na szczęście już w języku polskim  – znajdziemy kilka grup linków:

  • prowadzących od razu do odpowiednich sekcji w Konsoli Google, dotyczących domeny, dla której zostało wysłane do nas powiadomienie
  • do materiałów pomocnych dla webmasterów, zlokalizowanych w Pomocy Google
  • Forum Pomocy Google dla Webmasterów – gdzie każdy webmaster może uzyskać darmową pomoc w sytuacji jak ma problemy związane z danym tematem

Jak wygląda powiadomienie można zobaczyć na poniższej grafice

Googlebot nie może uzyskać dostępu do plików CSS i JS w witrynie

Google jak widać nie zwalnia tempa – jeszcze gdyby informował o karach algorytmicznych :)

GD Star Rating
loading...
Googlebot nie może uzyskać dostępu do plików CSS i JS w witrynie - nowy komunikat Google, Googlebot nie może uzyskać dostępu do plików CSS i JS w witrynie - nowy komunikat Google, 5.5 out of 10 based on 14 ratings Googlebot nie może uzyskać dostępu do plików CSS i JS w witrynie - nowy komunikat Google
napisał/a 1322 artykułów na rzecz Bloga SEO

Działaniami z zakresu SEO zajmuję się nieprzerwanie od 2008 roku - swoje usługi świadczę w Polsce oraz na rynkach anglo- i niemieckojęzycznych. W 2010 roku roku założyłem pierwszego bloga SEO (na którym mam przyjemność Ciebie gościć) skierowanego stricte do właścicieli stron, na którym przystępnym językiem przybliżam zmiany w algorytmie oraz publikuję wskazówki odnośnie tego, jak rozwijać strony, aby rankowały wysoko w Google. Od 2008 roku jako Top Contributor pomagam webmasterom na Forum Pomocy Google dla Webmasterów, na którym jestem najdłuższym stażem TC.

Opinie i Komentarze

Krzysiek 28 lipca 2015, 16:36

No i co mam zrobić po otrzymaniu takiego maila?

Sebastian Miśniakiewicz 28 lipca 2015, 17:16

Jak we wpisie i powiadomieniu – trzeba sprawdzić, czy nie blokowane są jakieś zasoby CSS/JS; John wspominał, że to przeszkadza – biorąc pod uwagę, że jest nowy komunikat można wnioskować, że mamy potwierdzenie na to, że w pewnym stopniu taka blokada ma wpływ na ranking naszej witryny w wyszukiwarce

Krzysiek 28 lipca 2015, 17:24

Witam Panie Sebastianie.
Dostałem odnośnie dwóch moim stron postawionych na Joomla (strony stojące na WordPressie przeszły bez echa). Mój plik robots.txt wygląda tak:

Disallow: /administrator/
Disallow: /cache/
Disallow: /cli/
Disallow: /components/
Disallow: /images/
Disallow: /includes/
Disallow: /installation/
Disallow: /language/
Disallow: /libraries/
Disallow: /logs/
Disallow: /media/
Disallow: /modules/
Disallow: /plugins/
Disallow: /templates/
Disallow: /tmp/

Co powinienem usunąć żeby nie blokować css i js?

Sebastian Miśniakiewicz 28 lipca 2015, 17:35

Pewnie w którymś z folderów są pliki CSS/JS, które Google uznało za ważne – nie znam Joomli na tyle.
Wiem jednak, że kiedyś miałem przypadek, że ktoś w Disallow: /images/ zaczął trzymać grafiki do wpisów i zniknęły mu one z Google

Krzysiek 28 lipca 2015, 18:13

Dziękuje za naprowadzenie. Napiszę jak rozwiązałem ten problem, może komuś się przyda. Po otrzymaniu takiego maila naciskamy przycisk „Pobierz jako Google”. Następnie wybieramy „pobierz i zrenderuj”. Na dole pojawi nam się pobrany plik, w którego klikamy. Na nowej karcie zobaczymy jak Google widzi naszą stronę. Gdy przewiniemy ją na dół zobaczymy elementy którą są blokowane np. „http://adres.pl/media/plik.jpg”. Następnie w pliku robots usuwamy wpisy blokujące dane katalogi w tym przypadku „media”. Następnie znów pobieramy i rendujemy i sprawdzamy czy już jest dobrze.

Pozdrawiam

Sebastian Miśniakiewicz 28 lipca 2015, 18:20

Dzięki za komentarz :)

Keran 28 lipca 2015, 18:55

Witam, w przypadku Joomla! serii 3.4 najlepiej wgrać plik robots.txt z pliku robots.txt.dist najnowszej wersji Joomla! Z tego co zauważyłem w zmiana dotyczy 2ch folderów: zdjęto blokadę z /images i /templates. Ciekawe co z WP bo też widzę, że takie komunikaty się pojawiają.

Sebastian Miśniakiewicz 28 lipca 2015, 19:41

Dziwię się, że images dopiero teraz w Joomla odblokowali :)
Co do WP – trzeba byłoby zobaczyć, co się Google nie podoba – w domyślnie blokowanych folderach WP są jednak skrypty – wp-incluces zawiera foldery css i js …

Keran 28 lipca 2015, 19:55

Nie wiem czy „dopiero teraz” :) i kiedy to zmienili ale na pewno najnowsza wersja ma już taką poprawkę, co do wcześniejszych nawet nie wnikam bo nie mam takiej potrzeby :)

D_S 28 lipca 2015, 18:59

Katalog „/includes/” w WordPressie często zawiera JS.

Sebastian Miśniakiewicz 28 lipca 2015, 19:42

Dokładnie
Do tej pory jednak to nie przeszkadzało – pytanie, czy coś się zmieniło :)

Dominik Niedźwiecki 28 lipca 2015, 19:48

To Google bot czyta js? Wydawało mi się że miał z tym problemy i zalecało się wyłączenie obsługi js żeby zobaczyć „mniej-więcej” stronę oczami Google bota…

Sebastian Miśniakiewicz 28 lipca 2015, 19:54

Już od dawna czyta … John z ponad rok temu np zalecał przy linkach z programów partnerskich wstawianych za pomocą JS, aby dodawać im nofollow …

Dominik Niedźwiecki 28 lipca 2015, 20:18

Najwyraźniej coś przegapiłem, ale dobrze wiedzieć. Dzięki za info :)

Sebastian Miśniakiewicz 28 lipca 2015, 20:23

Spox :)

n242 28 lipca 2015, 21:24

Ok, a co jeśli dostałem takiego maila, ale tester pliku robots nie wskazuje żadnych błędów i zagrożeń, a używając metody zaproponowanej przez Krzyśka po zrenderowaniu strony tak jak ją widzi google na dole nic nie mam? Stona jest na Joomli więc robots.txt wygląda jak u Krzyśka. Gdzie mogę się dowiedzieć co jest niby blokowane i czy odblokowałem to jeśli pozmieniam wpisy robots, skoro nigdzie mi nie pokazuje błędów? Czy może dostałem tego maila tak na wszelki wypadek, bo szedł masowo?

Sebastian Miśniakiewicz 28 lipca 2015, 22:01

To nowy komunikat, nie sprawdzałem tych stron, dla których dostałem powiadomienie – nie mam jak teraz.
Skoro wszystko jest OK i robot widzi stronę poprawnie na chwilę obecną – na podstawie mojego stanu wiedzy – nie przejmowałbym się
PS
Ewentualnie „zahaczył” Johna na jakimś najbliższym hangoucie i podpytał osobiście, czemu tak się dzieje :)

Greg 30 lipca 2015, 14:01

Mam problem. Od jakiegoś czasu po wpisaniu site:domena.pl wyskakuje mi strona główna w wersji HTTPS. Nie korzystam z SSL, pisalem do administratorów hostingu aby wyłączyć SSL całkowicie. Stwierdzili, że to nie wina serwera. Jak się okazuje w Bingu też zaindeksowana jest wersja HTTPS. Co w tamim przypadku zrobić? preferowana domena jest ustawiona w Google, wpisałem kod przekierowania z HTTPS na HTTP niestety nie pomaga- wyswietla się strona, że hakerzy mogą ukraść dane.
Czy użyć wspomnianego w tym arcie narzędzia do usuwania adresów i dodać na nowo z http?

Sebastian Miśniakiewicz 30 lipca 2015, 14:11

Obstawiam jakieś problemy po stronie ustawień https czy providera – ale to musisz z nimi wyjaśnić; roboty pokazują w indeksie to,do czego mają dostęp – tym bardziej, że problem jest nie tylko z Google, jak piszesz…

Sebastian Miśniakiewicz 30 lipca 2015, 14:12

Jeżeli to Ty zadałeś pytanie na Forum Google, podając domenę – tutaj jej nie podałeś – to masz potwierdzenie, że tak to jest – https://productforums.google.com/forum/?utm_medium=email&utm_source=footer#!msg/webmaster-pl/-sT5c2y6_CU/BnHHtyReFgAJ
Jak nie Ty – też masz potwierdzenie, że często to provider „zawala sprawę” – a nie roboty wyszukiwarek

Greg 30 lipca 2015, 15:04

zwalają na google. wpisuje site:domena i wyświetla się tylko wersja https. W bingu tylko wersja https. boje się, że jeśli to ręcznie usunę stronie mocno się oberwie:(

Sebastian Miśniakiewicz 30 lipca 2015, 16:11

Jak napisałem – moim zdaniem problem jest z ustawieniem usługi
To Twój wątek na Forum?

Skomentuj

Twój adres e-mail nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Zobacz inne wpisy z tej kategorii